DayPilot Lite Compatibility

 Browsers

  • Internet Explorer 7
  • Internet Explorer 8
  • Internet Explorer 9
  • Internet Explorer 10
  • Firefox 3+
  • Safari 3+
  • Opera 9+
  • Google Chrome

DocTypes

  • XHTML 1.0 Transitional
  • XHTML 1.1 Transitional
  • HTML 4.01 Transitional
  • HTML 5

Note: There might be minor issues in quirks mode (no <!DOCTYPE> specified). It works but there might be a bad pixel here or there. DayPilot Scheduler might require some tweaking (IE7 in quirks mode).

Java (JRE)

  • Requires JRE 1.5 or higher

Application Servers

  • Tested with Tomcat 6, Tomcat 7

Interferences (custom JavaScript, CSS)

Both the DayPilot DOM tree and supporting JavaScript code are complex and it may interfere with the rest of your code, especially:

  • style sheets (CSS)
  • custom JavaScript

Sometimes it can be fixed inside DayPilot (especially the CSS). Please contact support@daypilot.org to check the options.

DayPilot for JavaScript, ASP.NET WebForms, ASP.NET MVC, Java